If the new plugin version is failing validation or crashing your host, it is due to our current third party installer solution improperly overwriting the old plugin bundle. Simply delete the plugin from your plugins folder and reinstall.

We are moving to a new, native Mac installer solution as soon as possible, as this is becoming an increasingly common frustration. Sorry for the inconvenience!